Notifications
Clear all

Problem mit der v0.9.1-0.9.3-0.9.0 testrelease  

Page 2 / 2

Danilo0702
Posts: 271
(@danilo0702)
Reputable Member
Joined: 1 year ago

Habe nach einer Pause heute auf die 0.9.3 gewechselt. Machte vorher aber noch einen Scan mit der ersten freigegebenen Testversion 0.9.0 und da funktionierte alles. Nun geht nichts mehr nach einem upgrade. Nach dem Kalibrieren will ich den Scan starten und da bricht er sofort ab. Oben rechts steht Firmware udefine. Wird denn die Firmware separat irgendwohin abgespeichert?

Fabscan Problem Firmware

 

Reply
6 Replies
mario
Posts: 442
Admin
(@mario)
Member
Joined: 2 years ago
Posted by: @danilo0702

Pi stecke ohne das ich was verändert habe an der "alten" SD, mir auf einmal eine andere Firmware angezeigt wird. Ist das gesammte OS nicht eigentlich nur auf der SD oder wird die

Die Firmware steckt tatsächlich im HAT. Die Firmware wird aber vom Pi auf dem HAT automatisch aktualisiert, wenn eine neue Version zur Verfügung steht. Beim starten wird die Firmware beim HAT abgefragt. Wenn die Kommunikation dann fehlschlägt, steht da sowas wie "Unknown". Da ich einen Fehler eingebaut habe in der letzten Testing Version, bzw. einen unfertigen Teil hochgeladen habe kommt es dort zu einem Fehler.

Posted by: @danilo0702

Ich bin zwar nicht der Programmierer, aber ich hoffe, mit meinen Posts zu Fehlern kann ich ein bisschen mit beitragen.

Auf jeden Fall sehr hilfreich!

Posted by: @danilo0702

Ich spiele schon mit dem Gedanken, mir einen zweiten Fabscan hinzustellen, der nur zum testen ist.

Nicht nötig. Ich empfehle dir eine zweite SD-Karte fertig zu machen. Auf einer lässt du dann den letzten funktionierenden Stand und eine nimmst du zum Spielen. Dabei kann das folgende Teil recht hilfreich sein:

https://amzn.to/3j6Kh02

Reply
Danilo0702
Posts: 271
(@danilo0702)
Reputable Member
Joined: 1 year ago

Ich hab schon 2 SDs und dein Tipp mit der Verlängerung ist Gold wert. Der Gedanke, mir einen zweiten hinzustellen, ist der: Auf der einen SD ist das funktionierende OS, welches mit dem Hat 100% kompatibel ist. Wenn aber durch ein upgrade bei der "Test-SD"  auch die Firmware erneuert wird und diese aber mit dem funktionierenden OS nicht funktioniert, stehe ich ja dann auch wieder hilflos da. 

Reply
Page 2 / 2
Share: