Calibration Problem...
 
Notifications
Clear all

Calibration Problem: no Laser, no turn turntable movement during calibration

1 Posts
1 Users
0 Likes
50 Views
uro
Posts: 5
 uro
Topic starter
(@uro)
Active Member
Joined: 2 months ago

Hi all,

I'm using:

PI 4

UNO (Clone) with fabscanshield (TMC2209)

two laser and a stepper (400 Steps).

PI Cam

The server version is 0.10.2

Everything works fine using the webinterface (Switching both laser, the turntable and the LED ring). 

Starting the calibration nothing happends (no turntable movement, no lasers on)

The log File shows

2022-11-08 14:15:28,324 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.FSCalibrationActor: Step 3 of 102 in MODE_AUTO_CALIBRATION.
2022-11-08 14:15:31,106 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.FSCalibrationActor: Corners detected...
2022-11-08 14:15:31,108 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.FSCalibrationActor: Appending new points ...
2022-11-08 14:15:34,116 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.driver.FSSerial: Serial read timeout occured, skipping current and waiti ng for next command.
2022-11-08 14:15:37,120 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.driver.FSSerial: Serial read timeout occured, skipping current and waiti ng for next command.
2022-11-08 14:15:37,121 [609:2608854080] DEBUG - fabscan.scanner.laserscanner.driver.FSSerial: Send/Receive Error: 'NoneType' object has no attribute 'decode'
2022-11-08 14:15:37,123 [609:2608854080] DEBUG - 

I have no idea. Any ideas from Your side?.

Best regards

Uwe

 

Reply
Share: