Second Laser: when?
 
Notifications

Second Laser: when?  

  RSS
iadegesso
(@iadegesso)
Active Member

Hi all,

reading some post in this new forum, I met some people who mounted the second laser unit and the pictures they posted show this second laser on (so there is a red cross on the scan plate).

The version 0.7.0 of the FabScan Server is now supporting the second laser?

 

Thanks,

 

Iade Gesso, PhD

Quote
Posted : 19/04/2019 11:38 am
mario
(@mario)
Member Admin

Work in progress. Hopefully within the next release. 

 

53155180 2658159900921944 794672531486277632 n
ReplyQuote
Posted : 21/04/2019 4:48 pm
iadegesso
(@iadegesso)
Active Member

I'm waiting a lot for it 🙂

 

Iade

ReplyQuote
Posted : 02/05/2019 10:30 pm
mario
(@mario)
Member Admin

We are getting closer. The new software release will come soon! I am doing some final testing at the moment. But it looks already promising. 

D9rgSVvWsAEQdq6
D99l1BnWsAA2hdh.jpg large
 
This was just a quick test with the lowest resolution. I am also working on a fix for the "high res scan abort bug".
This post was modified 8 months ago 3 times by mario
ReplyQuote
Posted : 26/06/2019 7:23 am
iadegesso
(@iadegesso)
Active Member

Hi @mario,

this is a very good news. Is the new code available on GitHub?

 

Best regards,

Iade Gesso, PhD

ReplyQuote
Posted : 01/07/2019 5:12 pm
mario
(@mario)
Member Admin

The latest work on new releases is always located in the develop branch. But keep in mind that it is not stable yet.

ReplyQuote
Posted : 01/07/2019 5:23 pm
mario
(@mario)
Member Admin

Those scans were made by the ciclop scanner. The next release of the FabScanPi software will be compatible to the BQ Ciclop and china clones. 

snapshot bunny00
IMG 20190618 213818
IMG 20190622 214143
IMG 20190618 202337
This post was modified 8 months ago 4 times by mario
ReplyQuote
Posted : 01/07/2019 9:18 pm
Danilo0702
(@danilo0702)
Estimable Member

I've already mounted the second laser (red  laser because i cant find a blue or green laser) on the HAT with the Pi 3B on Fabscanpi. Is this supported or do I must buy a new HAT?

This post was modified 8 months ago by Danilo0702
ReplyQuote
Posted : 04/07/2019 10:26 am
mario
(@mario)
Member Admin

Sure. The HAT will work. But the new FabScan Pi version will support additional Hardware. Example gives the ciclop board. 

ReplyQuote
Posted : 04/07/2019 9:01 pm
iadegesso
(@iadegesso)
Active Member

Hi Mario,

I just connected the second laset to the FabScanPi HAT, but I need to manually activate it because when I go to the scan panel (in preview mode) in the user interface only the first laser is on (software release 0.8.2, with all the Raspbian packages updated to the newest version available).

I ran the calibration process, but... when I start a new scan nothing is shown in the UI (and the Internet connection is correctly working)... I'm not so sure the second laser is used in calibration and scan processes. Is there any configuration step that I need to follow to enable the second laser?

 

Moreover, with the same software version, if I want to manually power on the led ring, when I click on the related button nothing happens (but during scans the led ring works correctly. Any idea?

 

Thanks,

Iade Gesso, PhD (in Computer Science)

ReplyQuote
Posted : 06/02/2020 10:17 am
iadegesso
(@iadegesso)
Active Member
Posted by: @iadegesso

Hi Mario,

I just connected the second laset to the FabScanPi HAT, but I need to manually activate it because when I go to the scan panel (in preview mode) in the user interface only the first laser is on (software release 0.8.2, with all the Raspbian packages updated to the newest version available).

I ran the calibration process, but... when I start a new scan nothing is shown in the UI (and the Internet connection is correctly working)... I'm not so sure the second laser is used in calibration and scan processes. Is there any configuration step that I need to follow to enable the second laser?

 

Moreover, with the same software version, if I want to manually power on the led ring, when I click on the related button nothing happens (but during scans the led ring works correctly. Any idea?

 

Thanks,

Iade Gesso, PhD (in Computer Science)

I forgot to mention that when I try to power on manually the led ring, in the log the following lines are added:

2020-02-06 11:33:43,526 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M05 R0 G0 B0;
2020-02-06 11:33:56,448 - fabscan.FSScanner - DEBUG - Hardware Device Function called...

 

Moreover, when I start the calibration process, since today, i get only a black square (even if in the preview mode the camera show correctly the image).

 

Iade

ReplyQuote
Posted : 06/02/2020 10:38 am
iadegesso
(@iadegesso)
Active Member
Posted by: @iadegesso

Moreover, when I start the calibration process, since today, i get only a black square (even if in the preview mode the camera show correctly the image).

Ok, this was because I set the two lasers as "interleaved", copying it from the Cyclop configuration.

 

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

 

Iade

 

2020 02 06 15 33 58 Window

 

ReplyQuote
Posted : 06/02/2020 2:40 pm
iadegesso
(@iadegesso)
Active Member
Posted by: @iadegesso

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

2020 02 06 16 11 23 Window
2020 02 06 16 37 37 Window
ReplyQuote
Posted : 06/02/2020 3:38 pm
iadegesso
(@iadegesso)
Active Member
Posted by: @iadegesso

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

2020 02 06 16 56 21 Window
ReplyQuote
Posted : 06/02/2020 3:58 pm
Share: