Notifications
Clear all

0.8.2 Scan fiert ein


Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

Habe bis letzte Woche die Beta der v 0.8.0 genutzt. Jeder Scanvorgang ist 100% durchgelaufen und bis auf, dass die 2 Scans (weiss/blau) nicht ganz genau zusammengefügt wurden, sahen die Scans top aus. Nun habe ich die 0.8.2 installiert und kein Scan will mehr nach einem update heute richtig funktionieren. Wenn ich den Haken bei automatischer Tiefenschärfe drin lasse, bricht der Scan bei 55% ab. Also das "X" im Browserfenster kann man betätigen und man hört, wie der Scanner den Scan abbricht, aber er scant einfach nicht. Hat jemand ne Lösung?

Reply
33 Replies
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Ohne Log ausgaben ist es schwer bis gar nicht einzuschätzen was da vor sich geht. 

Posted by: @danilo0702

Nun habe ich die 0.8.2 installiert und kein Scan will mehr nach einem update heute richtig funktionieren.

Wie wurde das Update installiert? Hast du eine neues Image installiert oder über die Update Funktion der FabScan Pi Software versucht?

Posted by: @danilo0702

Wenn ich den Haken bei automatischer Tiefenschärfe drin lasse, bricht der Scan bei 55%

Bei jeder Auflösungsstufe?

Posted by: @danilo0702

Also das "X" im Browserfenster kann man betätigen und man hört, wie der Scanner den Scan abbricht,

Was meinst du genau man hört wie der Scanner abbricht?

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mario , ich habe mir eine neue SD Karte besorgt und das Image da drauf gespielt (also neu installiert), weil ich die Beta gern als Backup haben möchte.

Bei aktiver automatischer Tiefenschärfe bricht der Scan immer ab, egal, wie die Auflösung ist.Nehme ich den Haken raus dann kann ich die Tiefenschärfe manuell einstellen. Sie sollte aber nie mehr sein, wie die Auflösung, weil dann bricht der Scan auch ab (( zB 75%/75%)).

Ich meine, wenn ich im Firefox auf meinem PC auf das Webinterface vom Pi zugreife, kann ich mit dem "X" Button den Scannvorgang abbrechen, da reagiert der Pi auf den Befehl. Aber wenn ich den Deckel vom Scanner öffne, sieht man keine Aktivität an den Läsern oder der Drehscheibe. Komisch ist aber, dass das Browserfenster auf dem PC aktualisiert wird und oben links die orangene Temperaturmeldung regelmässig eingeblendet wird. Also arbeitet der Pi noch. Ein log will ich später mal  hochladen, da ich grad mitten im scannen bin und Angst habe, mich per remote am Pi anzumelden.

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

eine Frage zu der log-Datei... welche der hier gezeigten wäre die eigentliche?

log Fabscanpi
Reply
mcinerney
(@mcinerney)
Joined: 3 years ago

Trusted Member
Posts: 60
Posted by: @danilo0702

eine Frage zu der log-Datei... welche der hier gezeigten wäre die eigentliche?

log Fabscanpi

@daniloo702

Sorry for the English, maybe Mario can translate, if needed or knows the answer to my question below.

I am still learning how to interface with my Raspberry PI.

Can you please tell me what software package you are using (Shown in your post)?

I am looking for the best one to use and I like what I see on your screen.

Thanks Much!

PS-I had to add a fan to my PI - it was overheating!!!

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

ich hab mal so eine logdatei mit angefügt.... einfach die Endung ".pdf" entfernen

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Der letzte aktuelle Log ist immer der wo keine Zahl dran hängt. Die Logs werden rotiert. Ich glaube nach Datei Größe. Das heisst soviel wie wenn die aktuelle fabscanpi.log eine gewisse größe erreicht wird sie archiviert in eine fabscanpi.<nummer>.log. Und es wird mit einer neuen fabscanpi.log weiter gemacht. Also ist immer der letzte log in der fabscanpi.log enthalten.  

Lassen sich .log nicht hochladen?

Hast du mal versucht deinen Pi mit einem Lüfter zu versehen? Ich glaube ich konnte beobachten dass die Software auch hängen bleibt wenn die CPU des Pi zu heiß wird. Das kann schon im einfachen Scan-Betrieb passieren. Möglicherweise sind unterschiedliche Threshold Einstellungen auch verschieden Rechenintensiv. 

Hier hatte ich mal einen ersten Lüfter Entwurf Online gezeigt: https://fabscan.org/community/general/new-software-release-v-0-8-0/ Der funktioniert bei mir recht gut. 

Als Lüfter kannst du zum Beispiel diese verwenden: https://amzn.to/2FEpjTH ( Affiliate Link )

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

  @mario , der  logg ohne Zahl sieht bei mir im Editor immer gleich aus und hat eine Grösse von rund 2 kb und wurde auch nicht erneuert.

Diese Datei ist von 10.25 Uhr, obwohl ich gerade (14.19 Uhr) feststellte, dass der aktuelle Scan auch nicht funktioniert. Deswegen sende ich mal die logdatei mit der aktuellen Uhrzeit auch mit.

 

2020-01-12 0900,050 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 0912,579 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 0921,126 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 0925,552 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 0957,865 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1038,018 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1025,403 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1022,786 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1048,259 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1018,658 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1023,235 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1023,195 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1020,718 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.
2020-01-12 1050,028 - fabscan.worker.FSImageWorker - DEBUG - Killed Worker Process with PID 651

Nein, logs lassen sich nicht hochladen. Ich hab pdf drangehängt

Das die Temperatur eine Rolle spielt, hatte ich schon oft gemerkt. Zuletzt hatte ich den Pi im Keller bei 10 Grad, da lief jeder Scan. Nun steht er im Arbeitszimmer bei 24 Grad und er will nicht, obwohl im Poppupfenster des Browsers die gleichen Temperaturen zu sehen sind (ca 86 Grad).

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago
Posted by: @mcinerney

Can you please tell me what software package you are using (Shown in your post)?

Looks like ProFTP.

Reply
mcinerney
(@mcinerney)
Joined: 3 years ago

Trusted Member
Posts: 60

@mario

Well - a FTP client was my first guess and you confirmed it!

Thanks much!!!

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mcinerney its Filezilla --- on windows i use putty - on linux i use the terminal

 

Reply
mcinerney
(@mcinerney)
Joined: 3 years ago

Trusted Member
Posts: 60

@danilo0702

Thanks much - I knew the screen looked familiar.

Have a good day.

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago
Posted by: @danilo0702

Filezilla

Sure. Exactly what i meant. ProFTPD is a Server. My mistake.

Reply
mcinerney
(@mcinerney)
Joined: 3 years ago

Trusted Member
Posts: 60

@mario

No Problem, It works great!!

Keep up the good work!

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mario --  jetzt hab ich mal ne Aquariumpumpe an den Pi zur Kühlung geklemt und zack war die Temp auf 58 Grad.... Desweiteren funktionierte auch die logdatei diesmal. Wie du an den Uhrzeiten sehen kannst, wurden einzelne Zeitabschnitte gar nicht registriert, obwohl der Pi die ganze Zeit lief. Bei der Endung das .pdf entfernen

Reply
mario
Admin
(@mario)
Joined: 4 years ago

Member
Posts: 565

@danilo0702

Läuft der Scan denn wieder durch?

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mario ich bin grad am testen bei 75% Auflösung und automatischer Tiefenschärfe. Hab mal schnell ne alte Festplatte demontiert, um den Motor zu bekommen. Hab mir ein Lüfterrad (Ø 7 cm ) gedruckt, draufgeklebt und unter den Pi gelegt. Sieht gut aus bis jetzt. In 70 min weiss ich mehr.

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Cool! Später bitte Bilder von der Konstruktion! ? 

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

Ich glaub, das ist die Lösung.... Der Lüfter sitzt genau unter dem Treiber und ich habe konstant 69 Grad bei 75% Auflösung und der Scan läuft durch--- noch 6 von 140 min.

laut log:  .......fabscan.FSScanner - DEBUG - CPU Temperature: 68.76 C.

Ich glaube aber, dass diese kleinen Lüfter, wie sie bei 3D Druckern eingesetzt werden, zu klein sind. Werde mir morgen erstmal ein Kanal für den Lüfter konstruieren, der noch mehr auf den Treiber und den Pi bläst. Vorteil dieses HDD Motors, er ist leise und läuft mit 5V. Den könnte man auch direkt über den Pi mit Strom versorgen.

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Wichtiger als eine Treiber Kühlung ist die CPU Kühlung des Raspberry Pi. Dieser ist wesentlich kritischer. Denn der Pi wird langsamer je heißer er wird. Und irgendwann ist er so langsam dass er stehen bleibt. Wenn die Treiber heiß werden und Schritte verlieren ist maximal der Scan misslungen. Weil der Pi das im Prinzip nicht mitbekommt wenn der Treiber zu heiß wird.

Du musst also versuchen irgendwie Luft zwischen das HAT und den Pi zu pusten. Am besten Richtung Prozessor. Leider habe ich keine Wärmebild Kamera sonst würde ich das mal gerne messen.

 

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

ja, aber der Lüfter ist so stark, dass die CPU auch Kühlung bekommt. Im log steht was von 62 Grad durchschnittlich. Einziges Problem gestern abend nach dem ersten Versuch war, nachdem der Scan vollständig durchlief, dass beim zusammensetzen der 2 Einzelscans die Verbindung zum Pi abgebrochen ist. Der kleine hat zwar noch gearbeitet, aber ich hatte keinen Zugriff. Vielleicht hatte ich auch nicht lang genug gewartet, bis er fertig war.

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

der erste scan mit aktiver kühlung bei 75% Auflösung  und automatischer Tiefenschärfe. Die Temperatur steigt laut logfile nicht mehr über 62 Grad.

Das war genau das Problem. Wenn man keine automatische Tiefenschärfe benutzt und das ganze manuell regelt, so funktioniert es, nur bekommt man kein 100% iges 1:1 Abbild. Die Punkte werden in der Tiefe  ( nach hinten) leicht verzerrt abgebildet und es kommt zu Krümmungen. Ich rede  hier nur um Bruchteile von Millimetern....

 

Fabscanpi aktive Kühlung
Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

Hier ein Auszug aus dem log, als der Scan beendet wurde

 

2020-01-13 1226,028 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - G02 T16 F500;
2020-01-13 1226,034 - fabscan.scanner.laserscanner.FSScanProcessor - INFO - Finishing object scan.
2020-01-13 1226,730 - fabscan.scanner.laserscanner.FSScanProcessor - DEBUG - 3200 von 3200
2020-01-13 1226,777 - fabscan.scanner.laserscanner.FSScanProcessor - DEBUG - Time Total: 5143 sec.
2020-01-13 1226,796 - fabscan.scanner.laserscanner.FSScanProcessor - INFO - Scan complete writing pointcloud.
2020-01-13 1226,804 - fabscan.scanner.laserscanner.FSScanProcessor - DEBUG - Number of PointClouds (for each laser one) : 2
2020-01-13 1250,378 - fabscan.lib.util.FSDiscovery - INFO - Registering ip 10.0.0.37 to discovery service.
2020-01-13 1250,411 - fabscan.FSScanner - DEBUG - CPU Temperature: 63.91 C
2020-01-13 1251,551 - fabscan.lib.util.FSDiscovery - INFO - Successfully registered to find.fabscan.org
2020-01-13 1250,190 - fabscan.FSScanner - DEBUG - CPU Temperature: 64.45 C
2020-01-13 1250,187 - fabscan.FSScanner - DEBUG - CPU Temperature: 64.99 C
2020-01-13 1250,183 - fabscan.FSScanner - DEBUG - CPU Temperature: 64.99 C
2020-01-13 1217,574 - fabscan.scanner.laserscanner.FSScanProcessor - INFO - Reseting scanner states ...
2020-01-13 1217,906 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M05 R0 G0 B0;
2020-01-13 1218,238 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M18;
2020-01-13 1218,246 - fabscan.FSScanner - INFO - Scan complete
2020-01-13 1219,944 - fabscan.scanner.laserscanner.driver.FSCamera - DEBUG - Cam Stream with Resolution (1640, 1232) stopped
2020-01-13 1250,170 - fabscan.FSScanner - DEBUG - CPU Temperature: 44.01 C
2020-01-13 1250,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 38.63 C
2020-01-13 1250,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 38.09 C
2020-01-13 1250,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 35.4 C
2020-01-13 1250,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C
2020-01-13 1250,169 - fabscan.FSScanner - DEBUG - CPU Temperature: 35.94 C
2020-01-13 1250,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 35.94 C
2020-01-13 1350,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 35.94 C
2020-01-13 1350,166 - fabscan.FSScanner - DEBUG - CPU Temperature: 35.4 C
2020-01-13 1350,167 - fabscan.FSScanner - DEBUG - CPU Temperature: 36.48 C

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

hier 2 Fotos von der Sonntagabendidee :)

IMG 7858
IMG 7856
Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

also an der Temperatur liegts nicht mehr.... Der Pi bricht nach dem Scan einfach ab....((.pdf entfernen))

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Laut dem ersten log wurde der scan sauber abgeschlossen. Kannst du näher beschreiben was für dich ein Abbruch Verhalten darstellt. Schau auch mal bitte im Verzeichnis nach wo die scans abgelegt werden. Ich vermute eher das ein Fehler im benutzerinterface vorliegt und einfach was falsches angezeigt wird. 

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mario Ein Abbruchverhalten ist für mich, wenn der RPi fertig ist, aber der "X" Button im Browser immer noch zu sehen ist und ich mich dann erfolglos versuche, via Konsole oder ftp auf dem Pi einzuloggen. Ich muss dann den Scanner neu starten. Wo werden denn die Scans abgelegt, bevor sie im /home/pi/scans dir landen?

Reply
Danilo0702
(@danilo0702)
Joined: 3 years ago

Reputable Member
Posts: 391
Posted by: @danilo0702

@mario Ein Abbruchverhalten ist für mich, wenn der RPi fertig ist, aber der "X" Button im Browser immer noch zu sehen ist und ich mich dann erfolglos versuche, via Konsole oder ftp auf dem Pi einzuloggen. Ich muss dann den Scanner neu starten. Wo werden denn die Scans abgelegt, bevor sie im /home/pi/scans dir landen?

Ich vergass zu schreiben, dass ich natürlich dem Scanner genügend Zeit einräume und nichts überstürze....

Reply
mario
Admin
(@mario)
Joined: 4 years ago

Member
Posts: 565

@danilo0702

Posted by: @danilo0702

@mario Ein Abbruchverhalten ist für mich, wenn der RPi fertig ist, aber der "X" Button im Browser immer noch zu sehen ist und ich mich dann erfolglos versuche, via Konsole oder ftp auf dem Pi einzuloggen. Ich muss dann den Scanner neu starten. Wo werden denn die Scans abgelegt, bevor sie im /home/pi/scans dir landen?

Das der Pi sich so aufhängt das man sich nicht mal mehr einloggen kann das ist kein gutes Zeichen. Da stimmt dann aber auf Betriebssystem Ebene schon etwas nicht. Ich versuche das mal nachzustellen. Wie waren deine Scanner Einstellungen für den Scan? Volle Auflösung?

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

also das Verzeichnis var/scans/ war leer

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

75% Auflösung bei automatischer Tiefenschärfe. Ich scanne nie mit Farbe, da ich nur die reine Geometrie brauche. Temperatur war ok.

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

@mario Ich habe mich die halbe Nacht rumgeschlagen und wahrscheinlich den Fehler gefunden... Es liegt höchstwahrscheinlich nicht am Betriebssystem. Meiner Meinung nach läuft es sehr sehr stabil. Ich habe hier ein Netzwerk im Haus mit einem Repeater, an den ich den Scanner angeschlossen habe. Dieser Repeater vergibt aber neue IP adressen intern. Ich konnte zufällig dieses Phänomen heute beobachten, wie der Browser richtig eingefroren ist und das WLAN Signal am PC kurz weg war. Ich werde mir jetzt einen Router besorgen, der nur für den RPi lokal zuständig ist. Ich habe grad einen Scan mit Textur gemacht und obwohl das doch empfindlich länger dauert, sieht das Ergebnis wie eine Fotografie aus.... geile Sache

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

mal eine Frage, weil ich finde nichts dazu. Wo speichert der Pi eigentlich die Daten, bevor sie ins /home/pi/scans dir abgelegt werden?

Reply
Danilo0702
Posts: 391
Topic starter
(@danilo0702)
Reputable Member
Joined: 3 years ago

ich möchte heute mal etwas zeigen: vorher-nachher--> konvertiert im externen Meshlab. 100% auf den zehntel Millimeter genau. Das ist der pure Wahnsinn.

Diese Kühlung hat genau das erreicht, was ich von diesem Scanner wollte. Danke Mario

 

Fabscanpi aktive Kuehlung vorher nachher
Reply
Share: