Weboberfläche zeigt...
 
Notifications
Clear all

[Solved] Weboberfläche zeigt nichts an während des scans  

  RSS
Paddy
(@paddy)
Active Member

Hallo zusammen,

sorry, wenn ich hier viel poste, aber ich will das Ding endlich zum laufen kriegen 😀

Ich arbeite mich nach und nach durch die Fehler durch...nachdem ich alles neu gemacht habe und auch einen andere Pi 3b+ eingesetzt habe, scheint es etwas besser zu laufen. Leider kann ich mir die Scan Ergebnisse noch nicht ansehen und während des scannens zeigt er mir in der WebUI nur den Hintergrund aber nicht den Scan. auch bei einem Farbscan zeigt er mir nicht die Kamera. im "Hauptmenü" kann ich unten links die Preview sehen.

Hier mal ein Auszug aus der Log:

2020-04-28 17:24:03,599 - fabscan.scanner.laserscanner.FSImageProcessor - DEBUG - No points in cloud... masking not possible.

2020-04-28 17:26:36,541 - fabscan.scanner.laserscanner.FSScanProcessor - DEBUG - Checking Hardware connections
2020-04-28 17:32:37,164 - fabscan.server.services.websocket.FSWebSocketHandler - DEBUG - Client disconnected
2020-04-28 17:32:37,290 - fabscan.server.services.websocket.FSWebSocketHandler - DEBUG - New client connected
2020-04-28 17:32:37,712 - fabscan.FSScanner - DEBUG - Upgrade available: False 0.8.2

 

Quote
Posted : 28/04/2020 5:46 pm
Paddy
(@paddy)
Active Member

2020-04-28 17:37:19,602 - fabscan.scanner.interfaces - DEBUG - Scanner Type is: laserscanner
2020-04-28 17:37:21,551 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Port in Config found
2020-04-28 17:37:21,557 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Latest available firmware version is: v.20190811
2020-04-28 17:37:23,868 - fabscan.lib.util.FSUtil - INFO - avrdude-original: Using autoreset DTR on GPIO Pin 7
2020-04-28 17:37:24,422 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Trying to connect Arduino on port: /dev/ttyAMA0
2020-04-28 17:47:26,127 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Installed firmware version: v.20190811
2020-04-28 17:47:26,128 - fabscan.scanner.laserscanner.driver.FSSerial - INFO - FabScanPi is connected to FabScanPi HAT or compatible on port: /dev/ttyAMA0
2020-04-28 17:47:28,136 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Connection baudrate is: 57600
2020-04-28 17:47:28,137 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Firmware flashing baudrate is: 115200
2020-04-28 17:47:28,138 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Reset FabScanPi HAT...
2020-04-28 17:47:28,469 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M18;
2020-04-28 17:47:28,799 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - G07;
2020-04-28 17:47:29,300 - fabscan.scanner.laserscanner.driver.FSCamera - DEBUG - Cam Stream with Resolution (800, 600) stopped
2020-04-28 17:47:29,301 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Reset FabScanPi HAT...
2020-04-28 17:47:29,629 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M18;
2020-04-28 17:47:29,959 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - G07;
2020-04-28 17:47:29,960 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Hardware controller initialized...
2020-04-28 17:47:30,215 - fabscan.scanner.laserscanner.FSScanProcessor - INFO - Laser Scan Processor initilized...FSScanProcessor (urn:uuid:c4ea5fb1-830a-4b94-a172-bbae2af4519b)
2020-04-28 17:47:30,216 - fabscan.server.FSWebServer - DEBUG - /usr/share/fabscanpi/
2020-04-28 17:47:30,246 - fabscan.FSScanner - INFO - Job scheduler started.
2020-04-28 17:47:30,246 - fabscan.FSScanner - INFO - Scanner initialized...
2020-04-28 17:47:30,247 - fabscan.FSScanner - INFO - Number of cpu cores: 4
2020-04-28 17:47:30,248 - fabscan.lib.util.FSDiscovery - INFO - Registering ip 192.168.178.89 to discovery service.
2020-04-28 17:47:30,292 - fabscan.server.services.websocket.FSWebSocketHandler - DEBUG - New client connected
2020-04-28 17:47:30,458 - fabscan - CRITICAL - Fatal error: HTTPSConnectionPool(host='find.fabscan.org', port=443): Max retries exceeded with url: /register.php (Caused by SSLError(CertificateError("hostname 'find.fabscan.org' doesn't match 'fabscan.org'",),))
2020-04-28 17:47:30,584 - fabscan.FSScanner - DEBUG - Upgrade available: False 0.8.2
2020-04-28 17:47:30,587 - fabscan.scanner.laserscanner.FSScanProcessor - DEBUG - Checking Hardware connections

ReplyQuote
Posted : 28/04/2020 5:51 pm
Paddy
(@paddy)
Active Member

Und laut dem Log ist er fertig, aber er speichert es nicht und die WebUI bleibt im "Scan-Modus" und beendet diesen nicht. Dadurch habe ich den Scan auch nicht als Datei verfügbar.

 

Ich bin für Hilfe tausendfach dankbar!

ReplyQuote
Posted : 28/04/2020 6:02 pm
Danilo0702
(@danilo0702)
Estimable Member

Er speichert diese zu 100% auf dem Pi. Du musst dich aber via ftp (ssh....) auf dem Pi einloggen. Die Weboberfläche funktioniert nicht so, wie es bestimmt war. Auch eine Nachbearbeitung musst du extern machen. Meshlab ist da ideal.

ReplyQuote
Posted : 29/04/2020 9:08 pm
Paddy
(@paddy)
Active Member

Wie kann ich per SSH die Datei rausziehen?

ich bin halt verwundert, weil bevor ich alles neu gemacht habe, konnte ich den scan an der WebUI verfolgen und auch sehen was er gespeichert hat. Verstehe halt nicht wieso das nicht mehr geht

ReplyQuote
Posted : 30/04/2020 5:38 am
Paddy
(@paddy)
Active Member

Gibt es vielleicht auch ein Discord Server oder ähnliches wo man quatschen kann? 

ReplyQuote
Posted : 30/04/2020 5:39 am
Danilo0702
(@danilo0702)
Estimable Member

indem du dich auf dem Pi einloggst und ins Verzeichnis wechselst.... Steht aber alles in der Doku..... Einfacher ist es mit einem FTP Client. Ich benutze Filezilla (den muss man mit Adminrechten starten)

 

ReplyQuote
Posted : 30/04/2020 8:08 am
fabscantj
(@fabscantj)
Active Member

@danilo0702
Paddy hat recht, ich habe den gleichen effekt. Während des Scans wird kein Fortschritt angezeigt und der Scan ist anschließend auch nicht auf dem PI, da nützt auch kein FTP, SSH etwas.
Meine Vermutung: Fehler (deadlock) im Motortreiber (der Firmware), siehe: https://fabscan.org/community/latest-release/fabscan-requires-internet-connection-to-work-or-will-hang-after-scan/

ReplyQuote
Posted : 23/05/2020 3:15 pm
Danilo0702
(@danilo0702)
Estimable Member
Posted by: @fabscantj

@danilo0702
Paddy hat recht, ich habe den gleichen effekt. Während des Scans wird kein Fortschritt angezeigt und der Scan ist anschließend auch nicht auf dem PI, da nützt auch kein FTP, SSH etwas.
Meine Vermutung: Fehler (deadlock) im Motortreiber (der Firmware), siehe: https://fabscan.org/community/latest-release/fabscan-requires-internet-connection-to-work-or-will-hang-after-scan/

nein, der Fehler sitzt ganz woanders...Schau im German Thread, wo ich als letztes vor 1-2 Tagen als letzter gepostet habe. Da hat Mario alles erklärt. Gedulde dich noch ein wenig. 

ReplyQuote
Posted : 23/05/2020 4:18 pm
fabscantj
(@fabscantj)
Active Member

@danilo0702, du hast viel geschrieben, meinst du diesen Post:
https://fabscan.org/community/german/scan-scheint-zu-laufen-auf-dem-bildschirm-erscheint-nichts/paged/6/#post-1308

Mit welcher Version kann man im Moment noch scannen?
Macht es Sinn ein vorbereitetes (älteres) Raspi-Image zu nehmen und NICHT zu upgraden?

ReplyQuote
Posted : 24/05/2020 1:02 am
stef1186
(@stef1186)
Eminent Member

Ja den Post meint er.

Soweit ich weiß kann man im Moment in keiner Version Scannen.

 

ReplyQuote
Posted : 24/05/2020 6:49 am
Danilo0702
(@danilo0702)
Estimable Member

@fabscantj   ja -- ich glaub auf Seite 4 oder 5 steht die Erklärung von Mario

ReplyQuote
Posted : 24/05/2020 8:34 am
fabscantj
(@fabscantj)
Active Member

@stef1186

Ich hatte auf die Version 0.8.2 mit dem fertigen raspi Image zurückgedreht, kalibriert, Steps für Motor in Config eingetragen, reboot - scans klappen, qualität mittelmäßig, aber geht

ReplyQuote
Posted : 25/05/2020 4:46 pm
mario
(@mario)
Member Admin

Ich habe heute einiges vorbereitet um das dauerhaft zu fixen. Es kann jetzt passieren, dass folgende Meldung beim apt-get update angezeigt wird: 

sudo apt-get update

Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease

Hit:3 http://archive.raspberrypi.org/debian buster InRelease

Get:1 https://archive.fabscan.org stable InRelease [3,956 B]

E: Repository 'https://archive.fabscan.org stable InRelease' changed its 'Origin' value from '. stable' to 'archive.fabscan.org'

E: Repository 'https://archive.fabscan.org stable InRelease' changed its 'Label' value from '. stable' to 'fabscan

In diesem Fall Ruhe bewahren 😀 und folgendes machen... (ACHTUNG: es ist wichtig das -get weg gelassen wird).

sudo apt update

Ihr werdet aufgefordert diese Aktion zu quittieren.

Do you want to accept these changes and continue updating from this repository? [y/N] y

Danach sollte dann auch wieder ein apt-get update wieder wie gewohnt funktionieren.

ReplyQuote
Posted : 25/05/2020 10:47 pm
mario
(@mario)
Member Admin

Gefixt. Einfach das neue Image verwernden: https://github.com/mariolukas/FabScanPi-Build-Raspbian/releases/tag/v.2020-05-27-00-08

ReplyQuote
Posted : 28/05/2020 5:33 am
Share: