Notifications
Clear all

[Solved] Calibration fails with Fabscan 2020-06-29  

Page 3 / 3

Adam
Posts: 15
 Adam
(@adam)
Active Member
Joined: 1 year ago

I keep getting like:

2020-07-01 17:14:55,276 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration: Laser calibration 0

2020-07-01 17:14:55,277 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Distance: 42.27911237196088

2020-07-01 17:14:55,279 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Normal: [-0.91542817 -0.00106376  0.40247997]

2020-07-01 17:14:55,280 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Standard deviation: 4.87229466372726e-15

2020-07-01 17:14:55,280 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Point cloud size: 517

2020-07-01 17:14:55,463 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration: Platform calibration 

2020-07-01 17:14:55,468 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Center Point: [ -2.18673222  13.93603993 148.78706408]

2020-07-01 17:14:55,471 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Translation: [ -1.91526578  51.13503054 148.74960051]

2020-07-01 17:14:55,476 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Rotation: [[ 0.00000000e+00  9.99973373e-01 -7.29748500e-03] [-1.00711216e-03 -7.29748130e-03 -9.99972866e-01] [-9.99999493e-01  7.34938592e-06  1.00708535e-03]]

2020-07-01 17:14:55,478 [519:1202078816] INFO - fabscan.scanner.laserscanner.FSCalibration:  Normal: [-0.00729749 -0.99997287  0.00100709]

2020-07-01 17:14:55,481 [519:1202078816] DEBUG - fabscan.scanner.laserscanner.FSCalibration: Calibration Error

2020-07-01 17:14:55,482 [519:1202078816] ERROR - fabscan.scanner.laserscanner.FSCalibration: '<' not supported between instances of 'NoneType' and 'float'

 

Note that this is what I found in the logfile.

On the screen nothing indicates failure, it just told me 'Calibration Finished'

Reply
19 Replies
mario
Posts: 442
Admin
(@mario)
Member
Joined: 2 years ago

Bug fix version 0.9.1 is available now!

https://fabscan.org/community/general/new-release-v-0-9-1/

Reply
Adam
Posts: 15
 Adam
(@adam)
Active Member
Joined: 1 year ago

@Mario

I just installed the fixes that gave me version 0.9.3+202007072202 and indeed I have been able to run the calibration-process.

Now doing just another scan, which seems to work well.

Also, thanks for supporting 2 lasers now, I just ordered 2 of those...

Reply
Adam
Posts: 15
 Adam
(@adam)
Active Member
Joined: 1 year ago

Little bit off-topic but any idea why I do not show a mesh-filter (see picture)?

Also, 'download' has been misspelled...

Screen Shot 2020 07 11 at 18.11.34

 

Reply
Danilo0702
Posts: 271
(@danilo0702)
Reputable Member
Joined: 1 year ago

the Meshfilter dont works in the release. You will use the extern Meshlab program from http://www.meshlab.net/#download

Reply
Page 3 / 3
Share: