Problem with converting PLY to STL using integrated MeshLab  

  RSS
Japio-1955
(@japio-1955)
Active Member

I have the fabscan already for about a year and never get a good scan, I got PLY files but every program I uses (cura, 3dbuilder, enz.) gives errors on that type of file. I must admit that I also had little time for troubleshooting. 

But this the latest situation.

I have downloaded the last image (0.8.0) and put it on the pi3. With the calibration I get heat problems so I add a fan to the pi3. Calibration done (take while). Then I run the first scan and again I get a PLY (not readable as before). The I run the meshlab to convert to an STL file, I get only a popup which shows the start of meshlab, but I get never (even after a very long waiting time) a finished popup.

When I restart the fabscan the file folder (there is no option menu) don't show any scanned files, only when I start a new scan after when the option menu is available again, I can see all the scans I have made, but still no working meshlab.

I have retried different SD cards (al 16Gb), I have expand the space (raspi-config), I have now a PI4 with the same problems.

I have tried to install the fabscan completely on the latest raspbian versions (lite and full) but then I get to many (and for me not understandable) errors. So I went back to to the image.

Please help

Quote
Posted : 25/11/2019 11:29 am
Danilo0702
(@danilo0702)
Trusted Member

use meshlab extern... In the Fabscamsoftware the Meshfunktion will not works. When you get the Message """the teperature is 86.2 Grad""-- this is ok, no issue. And you can download the files with ftp-program.

ReplyQuote
Posted : 25/11/2019 3:48 pm
mario
(@mario)
Member Admin
Posted by: @japio-1955

I have the fabscan already for about a year and never get a good scan, I got PLY files but every program I uses (cura, 3dbuilder, enz.) gives errors on that type of file. I must admit that I also had little time for troubleshooting. 

PLY is a 3D Scanning raw format. It can not be used by any 3D Printing software and also not by the most CAD Software. You need to process those files with MeshLab or CloudCompare.

@japio-1955, @Danilo0702 is right. Those behaviors are already reported and I created also issues on GitHub. 

Download Issue: 

https://github.com/mariolukas/FabScanPi-Server/issues/134

MeshLab Isssue:

https://github.com/mariolukas/FabScanPi-Server/issues/136

This will be fixed within the next bugfix release. Hopefully before Christmas. As long as it is not fixed you should use MeshLab external as @Danilo0702 already mentioned.

 

Note: I created a new topic from your original post. The original post was not related to the other topic. 

This post was modified 2 weeks ago 2 times by mario
ReplyQuote
Posted : 25/11/2019 7:23 pm
Japio-1955
(@japio-1955)
Active Member

@mario

Thank you for this quick response.

I am sorry that I didn't read all the topics but it was to many and this was the easiest way.

So even when cura and 3dbuilder support the PLY extension, the PLY files from the fabscan are different I understand. So I have quickly installed Cloudcompare and I am glad to see that this was the issue. 

Again thanks.

ReplyQuote
Posted : 25/11/2019 9:08 pm
Share: