Notifications
Clear all

Second Laser: when?


iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago

Hi all,

reading some post in this new forum, I met some people who mounted the second laser unit and the pictures they posted show this second laser on (so there is a red cross on the scan plate).

The version 0.7.0 of the FabScan Server is now supporting the second laser?

 

Thanks,

 

Iade Gesso, PhD

Reply
14 Replies
mario
Posts: 569
Admin
(@mario)
Member
Joined: 4 years ago

Work in progress. Hopefully within the next release. 

 

53155180 2658159900921944 794672531486277632 n
Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago

I'm waiting a lot for it :)

 

Iade

Reply
mario
Posts: 569
Admin
(@mario)
Member
Joined: 4 years ago

We are getting closer. The new software release will come soon! I am doing some final testing at the moment. But it looks already promising. 

D9rgSVvWsAEQdq6
D99l1BnWsAA2hdh.jpg large
 
This was just a quick test with the lowest resolution. I am also working on a fix for the "high res scan abort bug".
Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago

Hi @mario,

this is a very good news. Is the new code available on GitHub?

 

Best regards,

Iade Gesso, PhD

Reply
mario
Admin
(@mario)
Joined: 4 years ago

Member
Posts: 569

The latest work on new releases is always located in the develop branch. But keep in mind that it is not stable yet.

Reply
mario
Posts: 569
Admin
(@mario)
Member
Joined: 4 years ago

Those scans were made by the ciclop scanner. The next release of the FabScanPi software will be compatible to the BQ Ciclop and china clones. 

snapshot bunny00
IMG 20190618 213818
IMG 20190622 214143
IMG 20190618 202337
Reply
Danilo0702
Posts: 394
(@danilo0702)
Reputable Member
Joined: 3 years ago

I've already mounted the second laser (red  laser because i cant find a blue or green laser) on the HAT with the Pi 3B on Fabscanpi. Is this supported or do I must buy a new HAT?

Reply
mario
Admin
(@mario)
Joined: 4 years ago

Member
Posts: 569

Sure. The HAT will work. But the new FabScan Pi version will support additional Hardware. Example gives the ciclop board. 

Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago

Hi Mario,

I just connected the second laset to the FabScanPi HAT, but I need to manually activate it because when I go to the scan panel (in preview mode) in the user interface only the first laser is on (software release 0.8.2, with all the Raspbian packages updated to the newest version available).

I ran the calibration process, but... when I start a new scan nothing is shown in the UI (and the Internet connection is correctly working)... I'm not so sure the second laser is used in calibration and scan processes. Is there any configuration step that I need to follow to enable the second laser?

 

Moreover, with the same software version, if I want to manually power on the led ring, when I click on the related button nothing happens (but during scans the led ring works correctly. Any idea?

 

Thanks,

Iade Gesso, PhD (in Computer Science)

Reply
iadegesso
(@iadegesso)
Joined: 3 years ago

Eminent Member
Posts: 32
Posted by: @iadegesso

Hi Mario,

I just connected the second laset to the FabScanPi HAT, but I need to manually activate it because when I go to the scan panel (in preview mode) in the user interface only the first laser is on (software release 0.8.2, with all the Raspbian packages updated to the newest version available).

I ran the calibration process, but... when I start a new scan nothing is shown in the UI (and the Internet connection is correctly working)... I'm not so sure the second laser is used in calibration and scan processes. Is there any configuration step that I need to follow to enable the second laser?

 

Moreover, with the same software version, if I want to manually power on the led ring, when I click on the related button nothing happens (but during scans the led ring works correctly. Any idea?

 

Thanks,

Iade Gesso, PhD (in Computer Science)

I forgot to mention that when I try to power on manually the led ring, in the log the following lines are added:

2020-02-06 1143,526 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - M05 R0 G0 B0;
2020-02-06 1156,448 - fabscan.FSScanner - DEBUG - Hardware Device Function called...

 

Moreover, when I start the calibration process, since today, i get only a black square (even if in the preview mode the camera show correctly the image).

 

Iade

Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago
Posted by: @iadegesso

Moreover, when I start the calibration process, since today, i get only a black square (even if in the preview mode the camera show correctly the image).

Ok, this was because I set the two lasers as "interleaved", copying it from the Cyclop configuration.

 

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

 

Iade

 

2020 02 06 15 33 58 Window

 

Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago
Posted by: @iadegesso

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

2020 02 06 16 11 23 Window
2020 02 06 16 37 37 Window
Reply
iadegesso
Posts: 32
Topic starter
(@iadegesso)
Eminent Member
Joined: 3 years ago
Posted by: @iadegesso

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

2020 02 06 16 56 21 Window
Reply
iadegesso
(@iadegesso)
Joined: 3 years ago

Eminent Member
Posts: 32
Posted by: @iadegesso
Posted by: @iadegesso

But now... after successfully calibrating the twin laser setup, with a threshold set about to the 75%, I get the preview in the attached image.

2020 02 06 16 56 21 Window

@mario any idea about the behaviour shown in the above posts?

Calibretion seems to be done correctly... When I did them the scanner has no black inside walls and plate... now I'm locked down, but... when I will come back to school, I will try to fix it... can it be due to the second laser that is non with fixed focus as the one shipped by Watterot?

 

Best regards,

Iade

Reply
Share: