Notifications

[Solved] Meshlab not working in 0.8.2  

  RSS
mcinerney
(@mcinerney)
Trusted Member

All,

It seems that the Meshlab interface in 0.8.2 is still broken, has anybody been able to get it to work?

When I select it in the GUI the screen flashes, but no file is produced and I do not get the extra duck folder.

@Mario - I know that all the documentation shows that you made the changes so it should work with the new Meshlab version. 

Thanks for all the help.  

Quote
Posted : 10/01/2020 2:24 pm
Danilo0702
(@danilo0702)
Estimable Member

download the file via ftp and use the  meshlabprogram

ReplyQuote
Posted : 10/01/2020 4:17 pm
mario
(@mario)
Member Admin

I tested it before i released 0.8.2. In fact of the meshing fails i need a log to see what is going on. 

Meshing can take several minutes. After pressing the button a message should appear. It says "Meshing started". After a couple of minutes (time depends on resolution file size of pointcloud etc...) another message should say "Meshing finished". Please keep in mind that the integrated meshing only works for simple objects like busts and so on. For more complex objects i always recommend to do multiple scans, download the ply's and mesh them external with meshlab and/or cloudcompare.

 

hase render

Difficult part of the object are the ears.

This rabbit was scanned by FabScan in two iterations. ( 2 single scans using 2 different positions). Pointclouds were aligned by using cloudcompare and finaly meshed by meshlab.

This post was modified 1 month ago 4 times by mario
ReplyQuote
Posted : 10/01/2020 4:41 pm
mcinerney
(@mcinerney)
Trusted Member

@mario

OK, I understand didn't know about the simple scan, that is good to know and have been using external meshlab.

Which log file do you need?

And, the Meshing Started message never appears. 

ReplyQuote
Posted : 10/01/2020 5:35 pm
mcinerney
(@mcinerney)
Trusted Member

Additional information;

Here is the list of log files in the fabscanpi directory, just let me know which one you need.

pi@fabscanpi:/var/log/fabscanpi $ ls -l
total 16332
-rw-r--r-- 1 root root 100 Jan 10 19:42 fabscanpi.log
-rw-r--r-- 1 root root 101 Jan 10 19:42 fabscanpi.log.1
-rw-r--r-- 1 root root 1694048 Jan 10 21:21 fabscanpi.log.2
-rw-r--r-- 1 root root 4999988 Jan 10 18:01 fabscanpi.log.3
-rw-r--r-- 1 root root 4999938 Jan 10 13:27 fabscanpi.log.4
-rw-r--r-- 1 root root 4999968 Jan 10 04:26 fabscanpi.log.5

Also, here is photo of the screen message that pops up when I press the "Start Meshing" button, this is the same if I choose .stl or .ply.  It says "No News Available".

Mesh Screen

Hope this helps and looking forward to your input. 

This post was modified 1 month ago by mcinerney
ReplyQuote
Posted : 10/01/2020 9:28 pm
mcinerney
(@mcinerney)
Trusted Member

All,

Never mind it is working now.  The only think I can figure out is that I was trying too large of a scan.

This is solved, sorry for the confusion. 

ReplyQuote
Posted : 11/01/2020 1:31 pm
Share: