Software 0.8.0 Prob...
 
Notifications
Clear all

Software 0.8.0 Problem

16 Posts
5 Users
2 Likes
6,922 Views
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

Hallo,

heute habe ich das Image der neuen Software 0.8.0 geflashed, leider erhalte ich wie bei der Version 0.7.0 folgende Fehlermeldung:

The FabScanPi server is currently not running

Die letzte Version, die bei mir gelaufen ist, ist 0.5.0. Ich habe mittlerweile eine getrennte Stromversorgung für den HAT und den PI realisiert, um eine evtl. Überlastung des Step-Down Wandlers auszuschließen. Anbei das logfile. Soweit ich das sehen kann, gibt es ein Problem mit dem HAT. Damit hatte ich bereits seit der Software 0.5.0 Probleme (Flash-Geschwindigkeit etc.). Sollte ich mir evtl. einen neuen HAT besorgen ?

pi@fabscanpi:~ $ cat /var/log/fabscanpi/fabscanpi.log
2019-11-10 14:56:31,106 - fabscan.server.FSScanServer - INFO - FabScanPi-Server 0.8.0+201911082051
2019-11-10 14:56:31,111 - fabscan.scanner.interfaces - DEBUG - Scanner Type is: laserscanner
2019-11-10 14:56:33,121 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Port in Config found
2019-11-10 14:56:33,127 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Latest available firmware version is: v.20190811
2019-11-10 14:56:35,330 - fabscan.lib.util.FSUtil - DEBUG - avrdude-original: Using autoreset DTR on GPIO Pin 7
2019-11-10 14:56:35,382 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - No FabScanPi HAT or compatible device found on port /dev/ttyAMA0
2019-11-10 14:56:35,383 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - Fatal FabScanPi HAT or compatible connection error....
2019-11-10 14:56:35,383 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Connection baudrate is: 57600
2019-11-10 14:56:35,383 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Firmware flashing baudrate is: 57600
2019-11-10 14:56:35,384 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Reset FabScanPi HAT...
2019-11-10 14:56:35,384 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - 'NoneType' object has no attribute 'write'
2019-11-10 14:56:35,385 - fabscan - CRITICAL - Fatal error: 'NoneType' object has no attribute 'flush'
2019-11-10 15:07:05,430 - fabscan.server.FSScanServer - INFO - FabScanPi-Server 0.8.0+201911082051
2019-11-10 15:07:05,435 - fabscan.scanner.interfaces - DEBUG - Scanner Type is: laserscanner
2019-11-10 15:07:07,348 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Port in Config found
2019-11-10 15:07:07,355 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Latest available firmware version is: v.20190811
2019-11-10 15:07:09,684 - fabscan.lib.util.FSUtil - DEBUG - avrdude-original: Using autoreset DTR on GPIO Pin 7
2019-11-10 15:07:09,735 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - No FabScanPi HAT or compatible device found on port /dev/ttyAMA0
2019-11-10 15:07:09,736 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - Fatal FabScanPi HAT or compatible connection error....
2019-11-10 15:07:09,736 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Connection baudrate is: 57600
2019-11-10 15:07:09,737 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Firmware flashing baudrate is: 57600
2019-11-10 15:07:09,737 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Reset FabScanPi HAT...
2019-11-10 15:07:09,738 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - 'NoneType' object has no attribute 'write'
2019-11-10 15:07:09,738 - fabscan - CRITICAL - Fatal error: 'NoneType' object has no attribute 'flush'
pi@fabscanpi:~ $

Grüße,

Ralf

Reply
15 Replies
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago

Hallo Ralf, 

die log Ausgabe lässt mich vermuten dass es ein Serielles Verbindungsproblem zum HAT gibt. Die Software versucht die neueste Software zu flashen, was nicht funktioniert. Wenn die Software an diesem Punkt scheitert, dann bricht der start Vorgang ab. Und es wird dir die Seite angezeigt die sagt das er Dienst nicht läuft. 

Posted by: @ralf02

The FabScanPi server is currently not running

Zurück auf v.0.5.0 gehen würde sicher zum jetzigen Zeitpunkt das gleiche Ergebnis liefer. In deinem Fall müsste sicher die Firmware händisch neu geflasht werden. Dafür gab es in der alten Doku eine Anleitung. Da ich die Doku aber umgebaut habe sind die F.A.Q Themen von der alten Doku ins neue Forum verschoben worden. Dort fehlen allerdings noch ein paar Bilder. Ich versuche im Laufe der nächsten Tage die Bilder nachzuziehen. 

Vorerst könnte dir das hier aber weiter helfen  https://learn.watterott.com/hats/rpi-uno-hat/bootloader/

Sobald ich alles umgezogen habe melde ich mich hier noch einmal.

Gruss

Mario

Reply
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

So ich habe heute nochmal die Software 0.5.0 probiert. Sie startet, aber es kommt in der Tat die Fehlermeldung "No Connection to arduino".

Bevor ich aber jetzt zu löten beginne für den Bootloader wollte ich nochmal probieren, die Firmware von Hand zu flashen. In meiner Anleitung, die ich mir geschrieben hatte, habe ich mir folgenden Befehl notiert, um die Firmware herunterzuladen:

wget https://raw.githubusercontent.com/mariolukas/FabScanPi-Server/master/src/fabscan/ firmware/v.20170709.hex

Wenn ich das so eingebe, kommt aber ".... not found ....".

Was wäre der korrekte Befehl, um die aktuelle Firmware herunter zu laden ?

(Flashen dann mit: sudo avrdude -D -V -U flash:w:v.20170709.hex:i -b 115200 -carduino -pm328p -P/dev/ttyAMA0)

Grüße,

Ralf

Reply
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago
Posted by: @ralf02

wget https://raw.githubusercontent.com/mariolukas/FabScanPi-Server/master/src/fabscan/ firmware/v.20170709.hex

Das ist auch eine alter Firmware. Was du flashen musst ist auf jeden Fall erst mal der bootloader. Die Firmware wird dann vom FabScanPi Server automatisch geflachst. die v.20170709.hex ist ohnehin fehlerhaft und wird früher oder später wieder zum problem führen. Nimm diese Datei.

wget  https://github.com/watterott/RPi-UNO-HAT/raw/master/software/bloader.hex 

Nach dem flachen einfach den FabScan v.0.8.0 auf die SD karte und Pi damit starten. Wenn du deinen Pi als Programmer angeschlossen hast. Dann flashen mit 

avrdude -c pi_isp -p m328p -e -U flash:w:bloader.hex:i -U lfuse:w:0xFF:m -U hfuse:w:0xD6:m -U efuse:w:0x05:m -U lock:w:0x0F:m

Schau dir noch mal die Anleitung hier an : 

https://learn.watterott.com/hats/rpi-uno-hat/bootloader/

Reply
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago

Ich habe aus der alten Doku den Punkt zum flashen noch mal überarbeitet und in die F.A.Q unter Hardware hinzugefügt.

https://fabscan.org/community/f-a-q/no-fabscanpi-hat-or-compatible-device-found/

Reply
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

So ich habe den Bootloader neu geflashed und ....... die Sofotware 0.8.0 funktioniert. Dann war die ganze Zeit wohl nur der zerschossene Bootloader das Problem.

 

Grüße,

Ralf

Reply
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago

Läuft der Scanner jetzt ?

Reply
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

Ja, die Benutzeroberfläche startet und ich konnte auch die Kalibrierung durchlaufen lassen. Dabei hatte sich der zweite Laser allerdings nicht eingeschaltet. Wird der zweite Laser in der Software 0.8.0 schon unterstützt bzw. müsste der bei der Kalibrierung einschalten ?

 

Grüße,

Ralf

Reply
f.haupt
Posts: 4
(@f-haupt)
New Member
Joined: 3 years ago

Ich kopiere mal aus einem anderen Thema:

Es ist wichtig das in deiner Konfigurationsdatei im Laser Teil das folgende drin steht: 

"laser": {
"interleaved": "False",
"numbers": 2,
"color": "R (RGB)"
}

 Danach musst du dann neu starten und anschließend die Kalibrierung neu durchführen. Wenn du das eingetragen hast solltest du auch im Settings Dialog zwei Laser ein und ausschalten können. 

Reply
Danilo0702
(@danilo0702)
Joined: 4 years ago

Reputable Member
Posts: 394
Posted by: @f-haupt

Ich kopiere mal aus einem anderen Thema:

Es ist wichtig das in deiner Konfigurationsdatei im Laser Teil das folgende drin steht: 

"laser": {
"interleaved": "False",
"numbers": 2,
"color": "R (RGB)"
}

 Danach musst du dann neu starten und anschließend die Kalibrierung neu durchführen. Wenn du das eingetragen hast solltest du auch im Settings Dialog zwei Laser ein und ausschalten können. 

selbst wenn in der Config alles richtig eingegeben ist, muss der 2. Laser nicht unbedingt leuchten. Bei mir war es einfach nur die falsche Polung. Ich habe die 2 Kabel vom Laser einfach an den Anschlüssen vertauscht

Reply
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago

Das stimmt. Ich werde die Doku noch einmal überprüfen. 

Reply
mcinerney
Posts: 60
(@mcinerney)
Trusted Member
Joined: 3 years ago

Sorry for the english!

@ralf02 - what resistor values did you use?

German Translation via Google.

@ralf02 - Welche Widerstandswerte haben Sie verwendet?
Reply
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

Okay, ich werde meine config mal überprüfen und die o.a. Eintragungen dort machen.

Ich habe den zweiten Laser so herum gepolt angeschlossen, wie es auf der Platine vorgedruckt ist (Plus-Kabel von Laser 2 an das äußere Ende der Schraubklemmen-Leiste, GND an die Klemme daneben nach "innen"). Müssen die Anschlüsse entgegen dem Platinenvordruck vertauscht werden ?

@mcinerney: Which resistors do you mean ?

 

Reply
mcinerney
(@mcinerney)
Joined: 3 years ago

Trusted Member
Posts: 60

@ralf02

Resistors for loading the blonder.hex file, but I figured it out, thanks for the help.

Reply
ralf02
Posts: 14
Topic starter
(@ralf02)
Active Member
Joined: 4 years ago

So ich habe die Änderungen in der Konfigurationsdatei vorgenommen. Der zweite Laser funktioniert jetzt und lässt sich auch manuell ein- und ausschalten. Allerdings hatte die Kalibrierung jetzt bei ca. 3 Minuten "remaining" plötzlich ohne Fehlermeldung abgebrochen.

Grüße,

Ralf

Reply
mario
Posts: 570
Admin
(@mario)
Honorable Member
Joined: 4 years ago

Moi

Posted by: @ralf02

So ich habe die Änderungen in der Konfigurationsdatei vorgenommen. Der zweite Laser funktioniert jetzt und lässt sich auch manuell ein- und ausschalten.

Das ist schon mal gut. 

Posted by: @ralf02

Allerdings hatte die Kalibrierung jetzt bei ca. 3 Minuten "remaining" plötzlich ohne Fehlermeldung abgebrochen.

 

Kannst du das Log File dazu schicken. Ansonsten versuch mal den Pi neu zu starten und die Kalibrierung erneut durchzuführen. 

Gruss

Mario 

Reply
Share: