Rpi Firmware  

Page 1 / 2
  RSS
amulaya
(@amulaya)
Active Member

hey,

My rpi was not booting with the custom image so I decided to use raspbian and follow instructions on the software section but when I'm trying to add directory to sources I get the error "permision denied" is there another way to install the firmware?

Quote
Posted : 14/03/2019 12:01 pm
AndreaCH
(@andreach)
Active Member

Hi Amulaya,
I also tried starting from a Raspbian-lite image, but I encountered problems in particular with the python-opencv-tbb package that I didn't understand where to find it.
Try instead to create the SD card with the FabscanPI image using the Rufus software (portable version)

https://github.com/pbatard/rufus/releases/download/v3.4/rufus-3.4p.exe

 

ReplyQuote
Posted : 18/03/2019 1:15 pm
amulaya
(@amulaya)
Active Member

I used flashed my sd card with the firmware and it booted but I'm not getting the interface. I can't find any instructions on what exactly I'm supposed to do after booting the rpi.

ReplyQuote
Posted : 19/03/2019 9:54 am
rene
 rene
(@rene)
Member Admin

Hi amulaya, does this mean that the GUI does not show or are you saying that you don't know what to do with it? In general, you can find the software documentation here: https://fabscanpi-server.readthedocs.io/en/latest/software/

 

ReplyQuote
Posted : 19/03/2019 10:04 am
amulaya
(@amulaya)
Active Member

Hey Rene,

It doesn't show, I followed all the steps till the software user manual but when I enter the ip address in my browser it says 'unable to connect'

ReplyQuote
Posted : 19/03/2019 10:13 am
AndreaCH
(@andreach)
Active Member

Can you ping fabscanpi ip address from your PC?

ReplyQuote
Posted : 19/03/2019 11:05 am
amulaya
(@amulaya)
Active Member

Yes I can ping it. There is no problem in pinging.

error log is:

2019-03-19 11:55:32,964 - fabscan.server.FSScanServer - INFO - FabScanPi-Server 0.7.0
2019-03-19 11:55:35,055 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Port in Config found
2019-03-19 11:55:35,063 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Latest available firmware version is: v.20190211
2019-03-19 11:56:26,704 - fabscan.lib.util.FSUtil - DEBUG - avrdude-original: Using autoreset DTR on GPIO Pin 7
2019-03-19 11:56:26,727 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - No FabScanPi HAT or compatible device found on port /dev/ttyAMA0
2019-03-19 11:56:26,727 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - Fatal FabScanPi HAT or compatible connection error....
2019-03-19 11:56:26,728 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Connection baudrate is: 57600
2019-03-19 11:56:26,728 - fabscan.scanner.laserscanner.driver.FSSerial - DEBUG - Firmware flashing baudrate is: 57600
2019-03-19 11:56:26,729 - fabscan.scanner.laserscanner.FSHardwareController - DEBUG - Reset FabScanPi HAT...
2019-03-19 11:56:26,729 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - 'NoneType' object has no attribute 'write'
2019-03-19 11:56:26,729 - fabscan - CRITICAL - Fatal error: 'NoneType' object has no attribute 'read'

ReplyQuote
Posted : 19/03/2019 12:09 pm
AndreaCH
(@andreach)
Active Member

2019-03-19 11:56:26,727 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - No FabScanPi HAT or compatible device found on port /dev/ttyAMA0
2019-03-19 11:56:26,727 - fabscan.scanner.laserscanner.driver.FSSerial - ERROR - Fatal FabScanPi HAT or compatible connection error..

 

Have you a FabscanPi HAT or compatibile card connected?

 

ReplyQuote
Posted : 19/03/2019 4:44 pm
mario
(@mario)
Member Admin

A similar issue was already reported at : https://fabscan.org/community/latest-release/software-release-v-0-7-0/

Please try the following command 

sudo /etc/init.d/fabscanpi-server stop 
sudo avrdude-autoreset -p m328p -b 115200 -carduino -P/dev/ttyAMA0


After that the output should look similar like:


avrdude-original: Using autoreset DTR on GPIO Pin 7

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f (probably m328p)

avrdude: safemode: Fuses OK (E:00, H:00, L:00)

avrdude done. Thank you.

In this case you should try to add the line:

"flash_baudrate": 115200

to the serial part of your FabScanPi config file. It should then look like:

"serial": {
"plattform_type": "fabscanpi",
"baudrate": 57600,
"autoflash": "True",
"port": "/dev/ttyAMA0",
"flash_baudrate": 115200
}

This post was modified 8 months ago 2 times by mario
ReplyQuote
Posted : 19/03/2019 7:53 pm
amulaya
(@amulaya)
Active Member

I'm using an arduino uno with cnc shield in place of hat. I had asked about it in the google group.

https://groups.google.com/forum/#!topic/fabscan/Cw7TkSnEQZw

ReplyQuote
Posted : 20/03/2019 8:24 am
amulaya
(@amulaya)
Active Member

Please try the following command 

sudo /etc/init.d/fabscanpi-server stop 
sudo avrdude-autoreset -p m328p -b 115200 -carduino -P/dev/ttyAMA0
WhatsApp Image 2019 03 20 at 2.03.13 PM
ReplyQuote
Posted : 20/03/2019 8:40 am
AndreaCH
(@andreach)
Active Member
Posted by: amulaya

I'm using an arduino uno with cnc shield in place of hat. I had asked about it in the google group.

https://groups.google.com/forum/#!topic/fabscan/Cw7TkSnEQZw

if you have connected arduino <-> raspberry via USB, you can try  /dev/ttyACM0 ... i think AMA0 is the built-in ttl serial device (FabscanPI HAT connect this device)

ReplyQuote
Posted : 20/03/2019 11:39 am
rene
 rene
(@rene)
Member Admin

Andrea is right, you need to change the name of the tty port if you use an external Arduino connected via USB instead of the official HAT.

You can list all relevant USB port with this command in your terminal or ssh connection:

ls -la /dev/ttyA*

if the list is empty, try this one:

ls -la /dev/ttyU*

 

ReplyQuote
Posted : 20/03/2019 12:03 pm
mario
(@mario)
Member Admin

Rene is right. That was a important missing information. I did not know that you are using a custom hardware. Mostly an Arduino on the USB port creates a device called

/dev/ttyUSB0

You can discover the correct device name by the method which Rene mentioned before. Then give the command i described before a try ( the following example with/dev/ttyUSB0).


sudo avrdude-autoreset -p m328p -b 115200 -carduino -P/dev/ttyUSB0

Finally don't forget to configure the port also in your

/etc/fabscanpi/default.config.json.

By the way the firmware pin settings should fit your board.

ReplyQuote
Posted : 20/03/2019 6:56 pm
amulaya
(@amulaya)
Active Member

The RPi is working perfectly, but any components connected to the arduino are not working.

I've been trying to resolve the issue on my own but couldn't. I've checked all individual components and they are all functional but when connected it isn't working. 

I think in the arduino code during execution it might be selecting the wrong board but I'm unable to find where that is happening.

I'm using the same code that Rene sent in the Google group. 

P. S. - is it possible that when I connect arduino to RPi it updates the firmware which might remove the CNC shield code? 

ReplyQuote
Posted : 28/03/2019 10:03 am
Page 1 / 2
Share: