Notifications
Clear all

Editing the config files permission denied.


Zeltrax
Posts: 3
Topic starter
(@zeltrax)
Active Member
Joined: 4 months ago

Hi guys,

 

Trying to get my bros ciclops scanner working after 5 years of it not being used. I built a sd card with the fabscan raspi image from this site so the settings are all default. 

 

When I go to edit the config file and the ciclop config I get permission denied.

 

When I look at the documentation I can't see anything about this ( I'm probably blind)

 

I am using MobaXterm to connect to the raspberry and using the text editor built in I even try just downloading the files and deleting the originials but still no luck.

Reply
7 Replies
leonnoel
(@leonnoel)
Joined: 2 years ago

Eminent Member
Posts: 49

@zeltrax Hello,  I am not familiar with the MobaXterm to be able to advise its use.  I have recently built a Ciclop unit from the Thingiverse designs to alleviate boredom and have it working to the point that I can get creditable scans with the default settings but there are still issues when trying to change scan settings with the browser window.

I do not find in the documentation where you need to change the config file or ciclop.config file but rather you do need to change the default.config.json file. I think the other files are changed as the unit is run (I may not be a newbie; I am definitely not an expert either).

I am guessing that you have a Ciclop with the Arduino Uno and a Zum hat on it for controlling the unit.  To which you have added a Raspberry Pi and Raspberry Pi camera.  Also, an LED light should be added for the calibration process.

Based upon experience with my unit:

The process would be to load the software to the SD card, go through setting up the regional parameters, wifi setup, etc.  Then the update and distribution upgrade and edit the default.config.json file.  Then reboot at which time you should be able to obtain a browser screen.  I have a spare hdmi monitor so use a keyboard and monitor to watch and control the Raspberry Pi activity rather than SSH. It will take about a minute for the LED light to flash for about 10 seconds at which time the web page will appear on your browser after the unit has rebooted. 

I had to change the default.config.json parameters from interleave: "True" back to "False" as no virtual image activity is shown on the browser screen during the scanning process (of course I don't really know what to expect and the virtual image activity is not really necessary for the completion of the scan).  What is significant is there is no point cloud in the .ply files.  One other change is also necessary. the number of rows, columns and square size of the calibration pattern must match the pattern used.  For me it is 6 rows. 11 columns and a square of 13 mm per side.  The data connection for the LED control is correct but the 5 volt and ground connections should be V and G as noted on the Zum board.

My equipment is:

A Ciclops constructed per Thingiverse with a 200mm table.  An Arduino Uno microcomputer.  A bare Zum board which has been populated with the 2 switching transistors and a silent step TMC2208 stepper driver and additional components (resistor, capacitor, terminals as required). A Raspberry Pi4 computer. A LED light.  Cloth screening to take the place of the box used with the FabscanPi scanner.

I have revised the Pi camera mounting to provide limited rotation about the Y axis for camera alignment. 

If you wish to take it that far I can provide *.stl  files of the camera mounting, table revision, a version of the alignment cone (copied from the Sardauscan design), a calibration cubic (for checking how well you have calibrated as after all a good scanner should be able to duplicate nearly perfectly if the calibration is right), and the printed brackets to use with 12mm wood dowels for the curtains.

Good Luck!

Reply
Zeltrax
(@zeltrax)
Joined: 4 months ago

Active Member
Posts: 3

@leonnoel 

 

So far I already got the prebuilt image on an SD card on my raspberry pi but I can't edit the text file to add their serial id on the config so I can get the raspberry to speak to the Arduino UNO. I've got a little experience in do something similar for 3D printing with klipper with a web interface but when I go to the ip address on the  browser i get a weird message so going to manually do everything instead of using the prebuilt image.

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i fabscanpi | grep -i python should show a python process:
    pi@fabscanpi:~ $ ps -ef | grep -i fabscanpi | grep -i python
    root 14674 1 77 11:19 ? 0002 /usr/bin/python /usr/bin/fabscanpi-serveri
    --config=/etc/fabscanpi/default.config.json --settings=/etc/fabscanpi/defaul t.settings.json
    --logfile=/var/log/fabscanpi/fabscanpi.log
  • If it isn't, the question is why. Take a look into /var/log/fabscanpi/fabscanpi.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service fabscanpi restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the https://fabscan.org/%2 2">FabScanPi Community Page. Please provide your Browser version and FabScanPi version as well as your fabscanpi.log and explain what you already tried and observed as detailed as possible.

 

Reply
mario
Posts: 565
Admin
(@mario)
Member
Joined: 4 years ago

Welcome @Zeltrax

if you are using the pi user for connecting to the Raspberry Pi, you need to use sudo in front of your editor command. All files in "/etc/" belong to the root user. You can get root user permissions by using sudo. 

In case you are using nano the command should be:

sudo nano /etc/fabscanpi/defaul.config.json

The error in your last post mostly means that the server is not starting up. In the most cases this happens when the fabscanpi-server is not able to flash the firmware to the arduino.

Check your configuration. Especially the baudrate. It is set to 14400 in case of the ciclop. When i implemented the firmware for the ciclop i have chosen 14400 because my ciclop is not an original by BQ. It is a cheap chinese clone. 

There are two baudrate configurations. One is for the serial communication, when the firmware is successfully flashed. The other one is for the flashing process. 115200 ( as it is default) should work. 

You should also check the name of your serial device. In case of an arduino it is something like

/dev/ttyUSB0

but this can also vary depending on the used arduino board.

- Mario

https://fabscanpi-server.readthedocs.io/en/latest/steps_ciclop.html#software-installation

 

Reply
Zeltrax
(@zeltrax)
Joined: 4 months ago

Active Member
Posts: 3

@mario Still getting the same message I changed the baudrate to what you said still no luck. The serial is connecting I can see it in the log file and i can see one of the lasers is turning on. but still no luck :/ Getting ready to give up on this.

 

 

Reply
Wolf2021
(@wolf2021)
Joined: 6 months ago

Eminent Member
Posts: 28

@zeltrax 

Hallo,

ich hatte vor 2 Monaten versucht ebenfalls meinen Ciclop auf den Fabscan pi zu portieren. Anfänglich hatte ich

Probleme mit dem Kalibrieren, was aber an der falsch montierten Kamera lag (90° Anschluss seitlich statt nach unten oder oben).

Wae dann soweit alles ok, lediglich das Scanergebnis mit viel Punktwolken außerhalb des Objektes. Habe dann wieder umgerüstet

und Kamera C270 eingebaut und die Horus-FW auf den Arduino geladen und Horus SW auf dem PC. Das passt besser zum Ciclop.

Ich hab mir dann den Fabscan pi zusammengebaut, da ich die Bauteile übrig hatte. Fabscan hat seine Stärke im geschlossenen Kasten

mit guten Scans. Ciclop ist offen und nicht so gegen Fremdlicht geschützt. Die Horus-SW bietet aber hier die Möglichkeit das Objekt

wie mit einer Glocke zu fixieren in Höhe und Breite, so dass alles außen herum ausgeblendet wird. Ich hoffe das hilft ein wenig über

den Frust. Grüße 

Reply
Wolf2021
(@wolf2021)
Joined: 6 months ago

Eminent Member
Posts: 28

Anbei die notwendigen Links zum Ciclop.

 

Reply
leonnoel
Posts: 49
(@leonnoel)
Eminent Member
Joined: 2 years ago

I am waiting for Mario to confirm but I thinkthis is as should be.  the Laser0 Is on by default at the beginning I'm assuming you are visually observing this and not on the web page of your browser.  You should be able to find your local IP by typing the command "ifconfig" return from SSH or your locally connected keyboard and monitor.  The IP should be displayed and you be able to find it and display your web page in either EDGE or FIREFOX.  This won't necessarily allow you to get a good calibration unless the /etc/fabscanpi/default.config.json file has the correct values but the fact that you have a laser on indicates to me that you have the port address right and the baud rate ok.  If you get the browser showing the web page I anticipate that you can control turning the LED on and off and the 2 lasers on and off.  One of the problems I remember that has happened is if I control the motor on and off, the system has to be rebooted to continue.  This seems to happen no matter if I am using a Ciclop or Fabscanpi unit.  I wouldn't give up yet but perhaps take a rest.

Reply
Share: