Notifications
Clear all

The FabScanPi server is currently not running (no logfile)


Evile
Posts: 2
Topic starter
(@evile)
Active Member
Joined: 1 month ago

Hi there, I'm trying to get Fabscan working with a ciclop scanner, but I'm getting the dread "The FabScanPi server is currently not running"  Error message in my browser. Ive checked in /var/log/fabscan, but the directory contains no log files.

The platform is Pi 3B+, I am using the fabscan SD image, with lightdm. I tried using both the default.config.json, and ciclop.config.json settings files with the same result. I have also updated linux

lsUSB

Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ps -ef | grep -i fabscanpi | grep -i python

 

root 1236 1 71 19:27 ? 0015 /usr/bin/python3 /usr/bin/fabscanpi-server --config=/etc/fabscanpi/default.config.json --settings=/etc/fabscanpi/default.settings.json --logfile=/var/log/fabscanpi/fabscanpi.log

 

Sytemctl status:-

● fabscanpi-server.service - FabScan Pi - Open Source 3D Scanner
Loaded: loaded (/lib/systemd/system/fabscanpi-server.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2021-11-01 1849 GMT; 24s ago
Main PID: 921 (fabscanpi-serve)
Tasks: 1 (limit: 725)
CGroup: /system.slice/fabscanpi-server.service
└─921 /usr/bin/python3 /usr/bin/fabscanpi-server --config=/etc/fabscanpi/default.config.json --settings=/etc/fabscanpi

Nov 01 1849 fabscanpi systemd[1]: Started FabScan Pi - Open Source 3D Scanner.
~

Reply
2 Replies
mario
Posts: 559
Admin
(@mario)
Member
Joined: 3 years ago
Posted by: @evile

Ive checked in /var/log/fabscan, but the directory contains no log files.

The logs are located in /var/log/fabscanpi 

Mostly the issue of non running daemon is caused by the serial connection which is not working. You should have a look into /dev to find the correct device name. The default for ciclop in the config is /dev/ttyUSB0. But the ciclop hardware can diversify. 

the default.confg.json will not work because the default is set to the firmware for the fabscanpi HAT. The cilcop config is set to the firmware for the ciclop. During the startup the server will flash the configured firmware to the board. The server will quit when this process fails. One possible reason for failure is a wrong serial port setting.

 

Reply
Evile
Posts: 2
Topic starter
(@evile)
Active Member
Joined: 1 month ago

Sorry, yes I meant /var/log/fabscanpi, bad typing :)
This appears to be correct I believe the CH341 is a popular UART for cheap Chinese Arduino clones.

Is there a way to start the daemon interactively so I can see the output on-screen?

Thank you so much for your help!

Contents of default.config.json

"connector": {
"type": "serial",
"firmware": "ciclop",
"baudrate": 14400,
"autoflash": "True",
"port": "/dev/ttyUSB0",
"flash_baudrate": 115200

dmesg | grep "tty"

[ 0.000983] printk: console [tty1] enabled
[ 3.349393] 20201000.serial: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2
[ 7.998636] systemd[1]: Created slice system-getty.slice.
[ 22.457526] usb 1-1.4: ch341-uart converter now attached to ttyUSB0

Reply
Share: