Notifications
Clear all

Problem importing into meshlab and meshmagic  


Vimatmo
Posts: 6
(@vimatmo)
Active Member
Joined: 1 month ago

My scans finished and looks good and then I downloaded it to my computer(options-download). I tried-both,-0,-1.  I try to import it into meshmagic or meshlab and I get an error saying there is a problem with the file. Is there something I am doing  wrong? Did I miss something in settings? Any ideas?

Reply
Topic Tags
3 Replies
leonnoel
Posts: 26
(@leonnoel)
Eminent Member
Joined: 7 months ago

I am attaching a screen shot of part of a .ply file displayed with notepad++.  Please look at yours and see if they are similar.  In the first 15 lines which are the header lines before the data it will show the Fabscanpi software version (line 3) which should be 0.9.4 if you are using the latest. The element vertex number (line 5) should be = {total lines in the file-15 (number of header lines)}. Each data line gives x, y , z coordinates and 3 values for the RGB texture values.  If you look at it closely, it gives you the Z values for each turntable stop before starting on the next vertical scan.  In one software version the number was left at 0, but has been corrected.   It is also possible to import the files as comma separated data.

Screenshot (384)

Since the file is ASCII it can be edited with Notepad and the ++ version does show line numbers for easy calculating the nmber of data points. 

Reply
1 Reply
Vimatmo
(@vimatmo)
Joined: 1 month ago

Active Member
Posts: 6

@leonnoel thanks for the reply. My header looks exactly like yours. I am using the latest version 0.9.4.  Question: should the "element face " have a value other than "0"?

Reply
mario
Posts: 492
Admin
(@mario)
Member
Joined: 2 years ago
Posted by: @vimatmo

other than "0"?

0 as value for face is fine for a raw scan. face defines the number of triangles for a meshed scan. FabScan delivers only a pointcloud what means that the file only contains vertices (points). The number of points is given by the vertex attribute in the header. This shouldn't be 0. 

Using 0.9.4 is the best way. There was an error several versions below 0.9.4 where vertex was returned with a value of 0. 

Can you copy and paste the log output of meshlab after you tried to open the file. The log is somewhere in the bottom right corner of the meshlab window. Which meshlab version are you using. Maybe you can provide the ply file and we can have a closer look.

- Mario 

Reply
Share: