Notifications
Clear all

Probleme beim Scan. Ergebnis sieht vielfach gespiegelt aus

Page 4 / 4

Danilo0702
Posts: 379
(@danilo0702)
Reputable Member
Joined: 2 years ago
Reply
4 Replies
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@danilo0702 Ich habe die Schritte über Putty auf 3200 reguliert. Danach habe ich den Scanner wieder kalibriert und einen Testlauf gemacht.

Das Ergebnis ist leider immer wieder gespiegelt.

Screenshot 2021 06 17 091709

 

 

Reply
mario
Admin
(@mario)
Joined: 3 years ago

Member
Posts: 537

@saar96 es ist super wichtig dass du den FabScanPi Server nach einer Änderung an der Konfiguration neu startest. Ansonsten werden die Änderungen nicht übernommen. Das kannst du entweder über einen Reboot tun oder indem du folgendes eingibst

sudo systemctl restart fabscanpi-server
Reply
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@mario das ist ein guter Tipp. Darauf habe ich noch nicht geachtet.

 

Reply
Danilo0702
(@danilo0702)
Joined: 2 years ago

Reputable Member
Posts: 379

@saar96 , das habe ich auf der vorhergehenden Seite aber schon erwähnt. :)

Reply
Danilo0702
Posts: 379
(@danilo0702)
Reputable Member
Joined: 2 years ago

Ich hab grad ein Dejavu. Ganz zu Anfang vor 2 Jahren hatte ich das auch mal. Dreht der Teller richtig rum (Uhrzeigersinn)?   Ich musste die 2 Kabel (glaub grün  und schwarz) vertauschen. Hast du auch die Laser richtig geschalten? Laser1 ist der vordere an der Klappe.

Vielleicht kann @mario hier mal schauen. 

Reply
1 Reply
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@danilo0702 Ich habe die Laser und den Motor überprüft und beides ist richtig angeschlossen. Sprich ist der 1. Laser, der an der vorderen Klappe und der Motor ist 2A (Rot), 1A (Blau), 1B (Schwarz), 2B (Grün) angeschlossen.

Reply
Danilo0702
Posts: 379
(@danilo0702)
Reputable Member
Joined: 2 years ago

ja, ist auch richtig so. Nur bei meinem Motor waren grün und schwarz genau umgedreht. Ich habe schwarz auf 2B und grün auf 1B

Reply
2 Replies
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@danilo0702 Wenn ich die Anschlüsse vertauscht anschließe und der Motor dreht jetzt linksrum. Das Scannergebnis ist auch nicht gut.

Screenshot 2021 06 18 081501
Reply
mario
Admin
(@mario)
Joined: 3 years ago

Member
Posts: 537

@saar96 das sieht jetzt aber nach einer echt schlechten Kalibrierung aus. Beide Punktwolken ( für jeden Laser eine) scheinen stark verschoben. 

Schau dir doch noch mal folgendes genauer an : https://fabscanpi-server.readthedocs.io/en/latest/scanner_calibration.html#prepare-for-calibration

Und nimm für den Anfang mal ein anderes Objekt. Kleine Figur oder ähnliches. Was ganz einfaches. Wenn du die Basis hinbekommen hast kannst du zu komplexeren Gegenständen wechseln, ansonsten kann es schnell frustrierend werden. Die Kalibrierung ist das wichtigste bei dem ganzen Setup.

Reply
Danilo0702
Posts: 379
(@danilo0702)
Reputable Member
Joined: 2 years ago

Das Doppelbild ist ja nun schon mal weg. Mit linksrum meinst du sicherlich "" in Uhrzeigerrichtung" und die Schritte hast du auch geändert (mit speichern und Neustart). Auch den Pi neukalibriert ((genau)) wirst du  gemacht haben. Dann klemme doch mal die 2 Drähte wieder so, wie du es vorher hattest. Softwareseitig läuft alles. Mit deiner Hardware stimmt was nicht.

Reply
1 Reply
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@danilo0702 Nach dem Tauschen der Anschlüsse, dreht der Schrittmotor wieder im Uhrzeigersinn und die Schrittzahl ist 3200. Ich habe den Fabscan über die Internetseite kalibriert. Ob der Pi jetzt auch kalibriert ist, weiß ich nicht.

Das Scannergebnis ist das beste, seit Beginn. Leider noch nicht ansatzweise so gut, wie bei vielen anderen.

 

Screenshot 2021 06 18 103826

Vielen Dank schonmal für die Hilfe bis jetzt. 

Mit welchen Teilen der Hardware stimmt etwas nicht?

Reply
Danilo0702
Posts: 379
(@danilo0702)
Reputable Member
Joined: 2 years ago

wie Mario oben schon schrieb, die Kalibrierung ist das A und O. Platziere das Sheet genau im Zentrum des Tellers parallel zur Kamera. Beide Laser müssen sich genau im Zentrum schneiden und lotrecht stehen. Du siehst im Browserfenster ein grünes Fadenkreuz. Das dient dir zum eistellen der Laser. Wenn du das gemacht hast rückst du das Sheet 10-15 mm Richtung Kamera und startest die Kalibrierung. Zum scannen danach nimm mal was ganz einfaches und nicht dieses Sheet. Auch das schrieb Mario.

Reply
3 Replies
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@danilo0702 Nach dem erneuten Ausrichten und kalibrieren, wird mir der Scan jetzt aus der falschen Perspektive angezeigt.

Screenshot 2021 06 18 103826
Reply
leonnoel
(@leonnoel)
Joined: 1 year ago

Eminent Member
Posts: 28

@saar96 This shifting of display axis has happened for me but a reboot seems to solve that problem.  Unless you have changed the configuration file since your lastest info displayed, it is important that the square size is 11 mm rather than 10mm  I have missed changing in the past and it causes problems.  Of course with your stepper motor 3200 steps are also required for a complete rotation of the turntable in a 16 microstep configuration.  Good luck

 

Reply
Saar96
(@saar96)
Joined: 2 months ago

Active Member
Posts: 17

@leonnoel A reboot solved the problem. Thanks

Reply
Page 4 / 4
Share: