Notifications
Clear all

[Solved] Communicate with FabscanPI HAT


AndreaCH
Posts: 10
Topic starter
(@andreach)
Active Member
Joined: 3 years ago

Hello,
is it possible to talk from Raspberry PI with the FabscanPI HAT card via (internal connected) serial to perform tests? I see in the configuration that Raspberry PI uses the device /dev/ttyAMA0, and I assume at 57600N81; but after running the software shutdown with "/etc/init.d/fabscan.server stop", with minicom program I can not communicate with the HAT card. From the logs I see that the Fabscan software communicates correctly with the HAT board and from the software the commands are correctly recognized by the HAT board. Is there any particular procedure to follow to connect with minicom? Thank you.
Andrea

-------------------------------------------------- -----------------------------
RaspberryPI 3B +, FabscanPI HAT, software v.0.7.0.

Reply
5 Replies
2 Replies
mario
Admin
(@mario)
Joined: 3 years ago

Member
Posts: 559

Hello, 

just tried to use minicom. Generally it works. But i am only able to send a M200 which will send back the firmware Version. Other commands don't work. Like M21 for turning on the laser. This seems to be a bug in the firmware. With python serial lib it seems to work just fine.

- Mario 

Reply
rene
 rene
Admin
(@rene)
Joined: 3 years ago

Member
Posts: 14

I installed screen on my Pi and was able to test all firmware commands that I was interested in, e.g. turn on/off the laser. 

Reply
helgetnt
Posts: 19
(@helgetnt)
Active Member
Joined: 3 years ago

Hello,

I have tested it too with minicom 2.7 and for me it worked with fabscanpi-server 0.7.0 started and stopped and

Firmware v.20190211.

I can turntable start/stop and both lasers on/off.

- Jens

Reply
helgetnt
Posts: 19
(@helgetnt)
Active Member
Joined: 3 years ago

@Andrea

Did you start minicom as ROOT ??? 

You can also test it with the following commands:

right laser ON

sudo echo "M21" > /dev/ttyAMA0

right laser OFF

sudo echo "M21" > /dev/ttyAMA0

 

Jens

Reply
AndreaCH
Posts: 10
Topic starter
(@andreach)
Active Member
Joined: 3 years ago

Thank you all,
I tried to call the minicom program as root, indicating the command line parameters

root@fabscanpi:/home/pi#
root@fabscanpi:/home/pi# /etc/init.d/fabscanpi-server stop
fabscanpi-server stopped.
root@fabscanpi:/home/pi# minicom -D /dev/ttyAMA0 -b 57600 -8

Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Apr 22 2017, 0919.
Port /dev/ttyAMA0, 2328

Press CTRL-A Z for help on special keys

M100
FabScan G-CODDE Interpreter Version: v.20190211
Commands:
G00 [T(steps)]; - linear move
G01 [T(steps)] [L(steps)] [F(feedrate)]; - move
M17; - enable motors
M18; - disable motors
M19; - turn left laser on
M20; - turn left laser off
M21; - turn right laser on
M22; - turn right laser off
M100; - this help message
M114; - report position and feedrate
>

and now it works. I do not know the minicom program enough ...

Andrea



Reply
Share: